Visual Studio 2013 'Could not evaluate Expression' Debugger Abnormality

Posted by: Rick Strahls WebLog, on 21 Nov 2013 | View original | Bookmarked: 0 time(s)

Last week I ran into a really strange problem with an older WebForms application on Visual Studio 2013.  I was trying to debug my application on a breakpoint and when I hit the break point, none of the debugger member and watch expressions were working - specifically everything shows 'Could not evaluate expression' in the debugger.  Here's what this looks like:In this example, you can see a couple of scoped values in the debugger. Here both this and user are in scope and instantiated, but...

Category: Debugger | Other Posts: View all posts by this blogger | Report as irrelevant | View bloggers stats | Views: 4097 | Hits: 60

Similar Posts

  • Visual Studio 2013 'Could not evaluate Expression' Debugger Abnormality more
  • "ADO.NET Entity data model" or "edmx" or "L2E" debug visualizer more
  • The State of the ViKi more
  • Mocking protected members with Moq more
  • LINQPad as a Code Snippet Execution Engine more
  • Developing Linq to LLBLGen Pro, part 8 more
  • Customizing Displays in the Debugger for System Types more
  • VB expression trees - string comparisons more
  • Expression Trees in C# 3.0 more
  • Express Yourself With Custom Expression Builders more

News Categories

.NET | Agile | Ajax | Architecture | ASP.NET | BizTalk | C# | Certification | Data | DataGrid | DataSet | Debugger | DotNetNuke | Events | GridView | IIS | Indigo | JavaScript | Mobile | Mono | Patterns and Practices | Performance | Podcast | Refactor | Regex | Security | Sharepoint | Silverlight | Smart Client Applications | Software | SQL | VB.NET | Visual Studio | W3 | WCF | WinFx | WPF | WSE | XAML | XLinq | XML | XSD